HP configurator stops by TypeError

Post Reply
Fist
Member
Posts: 26
Joined: Mon Aug 31, 2015 2:49 pm

HP configurator stops by TypeError

Post by Fist » Tue Nov 27, 2018 7:27 am

this is the second time in a row that our automatic workflow stops at the HP Smartstream VDP configurator.
Each time I get the same error:
Error in line 671 of script: TypeError Undefined memberfunction 'GetChildNodes' for object 'undefined' of type 'undefined'

Trough this Workflow hundreds of files run every day. Why does it stop?

How con I prevent it from happening and how can I be alerted that it happens?

regards.

F
Schermafbeelding 2018-11-27 om 06.49.05.png
Schermafbeelding 2018-11-27 om 06.49.05.png (76.87 KiB) Viewed 138 times

r.zegwaard
Member
Posts: 45
Joined: Fri Jul 08, 2011 10:31 am
Location: The Netherlands

Re: HP configurator stops by TypeError

Post by r.zegwaard » Wed Nov 28, 2018 7:18 am

Hi Fist,

What happens when you try to use this specific csv and the used template manually/directly in Indesign? So not via Switch.
Maybe that gives a clue what's wrong...

Robert

Fist
Member
Posts: 26
Joined: Mon Aug 31, 2015 2:49 pm

Re: HP configurator stops by TypeError

Post by Fist » Wed Dec 05, 2018 6:39 am

If I use the files directly they go trough without any problem. When I stop the flow and activate it again, the configurator works as it should be.

Could an other workflow causes the configurator to stop indesign?

It is really getting bad.

regards

r.zegwaard
Member
Posts: 45
Joined: Fri Jul 08, 2011 10:31 am
Location: The Netherlands

Re: HP configurator stops by TypeError

Post by r.zegwaard » Thu Dec 06, 2018 11:35 am

It might have something to do with the process which starts Indesign.
Is Indesign started as part of your boot-sequence, or is it started by a Switch-flow?
I guess the last options works, while the first don't.

Post Reply