XML Pickup does not pick up on random jobs...

Post Reply
Arthur
Member
Posts: 99
Joined: Sat Sep 09, 2017 11:58 pm
Location: Yateley, UK

XML Pickup does not pick up on random jobs...

Post by Arthur » Mon Feb 25, 2019 12:15 pm

Hi everyone;
I am having a bit of a weird issue. XML Pickup on some jobs does not pickup the XML.
Most of the jobs is going through just fine with the XML properly attached, some for no reason is not.
Both JOB Name and the XML name are identical.
Yet it does not pick up... See attached screenshot. To the right of the XML Pickup is a folder (the one that is just before the held connector) with jobs that went through fine.
Anyone had anything like that ?? I cannot see a set-up fault here, so would appreciate any hints as to why it can be happening.
XML_pickup Issue.png
XML_pickup Issue.png (33.53 KiB) Viewed 4788 times

LasseThid
Advanced member
Posts: 344
Joined: Tue Mar 03, 2015 2:30 pm
Location: Molndal, Sweden

Re: XML Pickup does not pick up on random jobs...

Post by LasseThid » Mon Feb 25, 2019 12:23 pm

I think you need to put a Job dismantler between the 7z_unpacked folder and the All unpacked folder as the unpacked jobs are folders not pdf files and the XML pickup is looking for a pdf and a matching xml file.
Enfocus Switch 2020 Fall Edition, Enfocus PitStop Server 2020, Enfocus PDF Review, HP SmartStream 12 & Kodak Prinergy 8.2 with RBA
Offset 72x102, Offset Large Format, Digital Large Format and Digital print.

Malcolm Mackenzie
Member
Posts: 99
Joined: Wed Mar 22, 2017 5:05 pm
Location: London, UK
Contact:

Re: XML Pickup does not pick up on random jobs...

Post by Malcolm Mackenzie » Mon Feb 25, 2019 12:57 pm

Hi Arthur
Are the failing files timing out?
Malcolm

Arthur
Member
Posts: 99
Joined: Sat Sep 09, 2017 11:58 pm
Location: Yateley, UK

Re: XML Pickup does not pick up on random jobs...

Post by Arthur » Mon Feb 25, 2019 1:16 pm

@ LasseThid - this is true, the unpacked files from 7z come as a folder. But the other jobs that went through fine - are on exactly the same basis, come as a job folder with docs inside. And the XML Pickup attached the XML just fine.

@ Malcolm - yes, they do time out. The logs show the following:
'Job '_0N77K_3410017 Dr. Jesus Mesones Patricia Ruth Guaraz.xml' was moved from folder 'D:/SwitchData/backing/Site Specific/automanaged/All unpacked' to the problem jobs folder. Reason: A metadata source is considered orphaned because it can't be matched to a counterpart'

'Job '_0N77L_3410017 Dr. Jesus Mesones Patricia Ruth Guaraz' was moved from folder 'D:/SwitchData/backing/Site Specific/automanaged/All unpacked' to the problem jobs folder. Reason: An incoming asset is considered orphaned because it can't be matched to a counterpart'

How come ?? Copied path, text on the rightclick to find out if there is maybe a whitespace anywhere in the name, but there is not.
This is what the renaming elements before take care of - to remove some unwanted '(\s{2,}) and replace with a single space, as the 7z by default makes all multiple spaces as just 1, so if there was any more in the initial Job, that would then result in the XML based on the initial [Job.NameProper] to be different than the result of the 7zip unpack operation. If this all makes sense.
Yet - most of the jobs are going fine, some do not...
Bug ??

Malcolm Mackenzie
Member
Posts: 99
Joined: Wed Mar 22, 2017 5:05 pm
Location: London, UK
Contact:

Re: XML Pickup does not pick up on random jobs...

Post by Malcolm Mackenzie » Mon Feb 25, 2019 1:32 pm

XML can be associated to folders as well as jobs.

Doesn't look like it should time out unless the setting is very short or matched files arrive to far apart?
See if the Error Log gives more details?

LasseThid
Advanced member
Posts: 344
Joined: Tue Mar 03, 2015 2:30 pm
Location: Molndal, Sweden

Re: XML Pickup does not pick up on random jobs...

Post by LasseThid » Mon Feb 25, 2019 1:55 pm

OK, good to know... I've always added a Job dismantler in my flows thinking they are needed in these cases...
Enfocus Switch 2020 Fall Edition, Enfocus PitStop Server 2020, Enfocus PDF Review, HP SmartStream 12 & Kodak Prinergy 8.2 with RBA
Offset 72x102, Offset Large Format, Digital Large Format and Digital print.

Arthur
Member
Posts: 99
Joined: Sat Sep 09, 2017 11:58 pm
Location: Yateley, UK

Re: XML Pickup does not pick up on random jobs...

Post by Arthur » Mon Feb 25, 2019 2:08 pm

It seems to be a bug ...
Just found out that when the initial filename is:

3410017 Dr. Jesus Mesones Patricia Ruth Guaraz <- this is not going to work.

If the same file is renamed so that there was no DOT after the Dr, so effectively the filename is:

3410017 Dr Jesus Mesones Patricia Ruth Guaraz <- this works fine.

All the other ones that went through fine, had no DOT in their [Job.NameProper].
I guess the XML Pickup shall work regardless, am I right ??

freddyp
Advanced member
Posts: 600
Joined: Thu Feb 09, 2012 3:53 pm

Re: XML Pickup does not pick up on random jobs...

Post by freddyp » Mon Feb 25, 2019 4:08 pm

The name of the job folder is "3410017 Dr. Jesus Mesones Patricia Ruth Guaraz", so for Switch the name proper is "3410017 Dr". The name of the XML is "3410017 Dr. Jesus Mesones Patricia Ruth Guaraz.xml", so the name proper is "3410017 Dr. Jesus Mesones Patricia Ruth Guaraz" and the two do not match.
That is the logical explanation, but I agree that in the case of a folder the whole name should be regarded as the name proper. I will report that.
Workaround: before the "XML pickup", send job folders to a "Rename job" that replaces all dots by nothing on the complete filename, and send job files to a "Rename job" that replaces all dots to nothing on the filename proper.
And if you really need the original name further on in the flow, make sure to "Remember original name - Yes". This will allow you to rename the job back to the original name later in the flow.

Arthur
Member
Posts: 99
Joined: Sat Sep 09, 2017 11:58 pm
Location: Yateley, UK

Re: XML Pickup does not pick up on random jobs...

Post by Arthur » Mon Feb 25, 2019 4:39 pm

Hi Freddy.
This is what I did, so the result is achieved, but as already agreed - this should not be required if the complete folder name was regarded as NameProper here.
Little things but can be a nightmare sometimes :)
Thank you for reporting it to the Team for amendment on future releases if possible.

Cheers

Post Reply