Using multiple checkpoints via email in flows

Post Reply
PdFUser5000
Member
Posts: 36
Joined: Fri Jun 12, 2020 11:23 am

Using multiple checkpoints via email in flows

Post by PdFUser5000 » Mon Sep 28, 2020 2:16 pm

When using multiple checkpoint via email elements, I sometimes get this error from another checkpoint via email element, to which i have not sent data at that moment:

Failed to receive message; error message: x0033 NO Some of the requested messages no longer exist.

Does this occur because I use the same email configuration for all of the elements( send and receive address)? Is this error safe to ignore, or should i change my settings? Is it possible to use email aliases?

Everything works at the moment, but i would like to be 100% sure that this error does not cause some mistakes in the future.

freddyp
Advanced member
Posts: 543
Joined: Thu Feb 09, 2012 3:53 pm

Re: Using multiple checkpoints via email in flows

Post by freddyp » Wed Sep 30, 2020 5:03 pm

Using multiple Checkpoint via mail elements using the same account can work because each element only takes the mails that are relevant for itself. It is possible that a problem occurs when both elements are accessing the mail box at the same time. When they try again the next time it will probably be OK again. I am careful here because it is not that easy to reproduce that.

One thing you can do to reduce the chance of the two elements trying to access the mail box at the same time is by giving them different intervals and make sure that they do not coincide often, so use prime numbers that are close together. If the interval is now 10 minutes, set one to 11 and the other to 13 for example.

Post Reply