Pitstop Server 2019 u1 - memory leak

Post Reply
epicprint
Newbie
Posts: 1
Joined: Thu Dec 12, 2019 9:25 pm

Pitstop Server 2019 u1 - memory leak

Post by epicprint » Thu Dec 12, 2019 10:12 pm

I just installed pitstop server on a 96core 200gig memory AWS instance running Windows 2019 Datacenter and I am getting a crazy memory leak. It basically starts wheree each PitStopServerLibProcessor.exe process using memory at 100megs, and each process grows to gigs and gigs eventually maxing out all 200 gigs.

Then, when it's finished processing the files (if it doesn't crash first due to windows being 100% maxed out), it remains at 99% memory usage... even though nothing is running.

This was happening on the original one and I updated to the new Update 1 and it's still happening.

Can anybody help? I made a support ticket a day ago with Enfocus but they are not very fast at responses.

Thanks in advance!

abailescollins
Advanced member
Posts: 380
Joined: Wed Apr 22, 2015 4:28 pm

Re: Pitstop Server 2019 u1 - memory leak

Post by abailescollins » Fri Dec 13, 2019 9:10 am

Can you drop me a mail with the details and the support ticket number please.
Will take a look.
andrewb@enfocus.com
PitStop Product Manager @ Enfocus.
andrewb@enfocus.com

abailescollins
Advanced member
Posts: 380
Joined: Wed Apr 22, 2015 4:28 pm

Re: Pitstop Server 2019 u1 - memory leak

Post by abailescollins » Fri Dec 13, 2019 9:30 am

Ok I found the case and I can see support have been in contact with you.
If you can follow the instructions about installing the diagnostic tool, that will give us a good steer on what is going on.
I will talk to development this morning and make them aware, it maybe that they will want to logon and take a look at the machine whilst it's running.
In the meantime the diagnostic tool is a crucial first step, as its going to give us a lot of important data.
PitStop Product Manager @ Enfocus.
andrewb@enfocus.com

Post Reply