OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post Reply
JaDe0051
Newbie
Posts: 11
Joined: Wed Mar 06, 2024 1:54 pm

OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post by JaDe0051 »

Hello everyone,

Is anyone else experiencing an issue where the OAuth 2.0 App, regardless of the version, suddenly reports the following error:
"Mail receive component failed during operation perform: Logging in is disabled on this server"
and only retrieves emails in very irregular, random, and extremely rare cases?

We suspect an issue on the Microsoft 365 side. We have made absolutely no changes to our environment: no updates, no modifications to the mail server, and no firewall changes. Everything was working flawlessly until yesterday morning.
The issue affects all app instances, each connected to different mailboxes. We have even tested with a newly created mailbox and a newly configured app instance, with the same result.
Has anyone else observed similar behavior or identified the root cause?
Thanks in advance.
Shawn_Anderson
Newbie
Posts: 14
Joined: Mon Apr 17, 2017 3:45 pm

Re: OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post by Shawn_Anderson »

Just started happening to me too. I thought it was related to a minor Mac OS update but apparently not. I can get it to work for a few minutes if I select the app and hit retry but it fails again almost immediately. Time to open a case.
freddyp
Advanced member
Posts: 1207
Joined: Thu Feb 09, 2012 3:53 pm

Re: OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post by freddyp »

Please let us know which version of the "Mail with OAuth2" you are using. The latest version is 6.3. You can already try updating to this version and also let us know if that helped.
Shawn_Anderson
Newbie
Posts: 14
Joined: Mon Apr 17, 2017 3:45 pm

Re: OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post by Shawn_Anderson »

freddyp wrote: Thu Aug 13, 2026 6:18 pm Please let us know which version of the "Mail with OAuth2" you are using. The latest version is 6.3. You can already try updating to this version and also let us know if that helped.
I am already using v6.3 of OAuth2 on a Mac.
JaDe0051
Newbie
Posts: 11
Joined: Wed Mar 06, 2024 1:54 pm

Re: OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post by JaDe0051 »

We are also using version 6.3, but the issue is not version-specific. Older versions exhibit the exact same error.
What we have observed is that, very rarely, the mail retrieval works once or twice a day without us making any changes. We have configured Switch to automatically retry all failed processes every five minutes. As a result, email retrieval occasionally succeeds again, seemingly at random, but only in very rare cases.
PdFUser5000
Member
Posts: 147
Joined: Fri Jun 12, 2020 11:23 am

Re: OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post by PdFUser5000 »

We are also having the same issue. Using ver 6.3. Sometimes, the automatic switch process retry is able to restart the flow, but it can also continue failing until we try a manual restart of the flow. Sometimes re-authorization gets it working again, but for a random period of time, before it fails again.
JaDe0051
Newbie
Posts: 11
Joined: Wed Mar 06, 2024 1:54 pm

Re: OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post by JaDe0051 »

Enfocus has identified the issue. Microsoft has made changes to Exchange, which are causing the problem. A new version 6.4 of the OAuth app is expected to be released today and should resolve the issue.
freddyp
Advanced member
Posts: 1207
Joined: Thu Feb 09, 2012 3:53 pm

Re: OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post by freddyp »

The 6.4 version is now online.
freddyp
Advanced member
Posts: 1207
Joined: Thu Feb 09, 2012 3:53 pm

Re: OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post by freddyp »

We have been running the 6.4 version in our production environment without any problems since yesterday. Can you confirm this?
Shawn_Anderson
Newbie
Posts: 14
Joined: Mon Apr 17, 2017 3:45 pm

Re: OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post by Shawn_Anderson »

Version 6.4 is working correctly for us as well.
JaDe0051
Newbie
Posts: 11
Joined: Wed Mar 06, 2024 1:54 pm

Re: OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post by JaDe0051 »

Yes with the new Version 6.4 is everything fine. ;)
PdFUser5000
Member
Posts: 147
Joined: Fri Jun 12, 2020 11:23 am

Re: OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post by PdFUser5000 »

The previous bug was fixed for us as well, but we are now facing a new dailiy error. Automatic retrying gets the connector working, but this error is reported several times a day:

Message: Mail receive component failed during operation perform: 18680000:error:0A00010B:SSL routines:ssl3_get_record:wrong version number:c:\ws\deps\openssl\openssl\ssl\record\ssl3_record.c:355:
Shawn_Anderson
Newbie
Posts: 14
Joined: Mon Apr 17, 2017 3:45 pm

Re: OAuth 2.0 Mail receive component failed during operation perform: Logging in is disabled on this server

Post by Shawn_Anderson »

PdFUser5000 wrote: Thu Sep 10, 2026 6:05 am The previous bug was fixed for us as well, but we are now facing a new dailiy error. Automatic retrying gets the connector working, but this error is reported several times a day:

Message: Mail receive component failed during operation perform: 18680000:error:0A00010B:SSL routines:ssl3_get_record:wrong version number:c:\ws\deps\openssl\openssl\ssl\record\ssl3_record.c:355:
We are getting the same SSL error as well. I have already opened a case. For the first few days it was just trying and timing out after a few minutes with X attempts left, then eventually working. Now it still shows the time out error, but occasionally throws the above SSL version error as well. I have 3 instances of OAuth and all show the error, but not always at the same time. Sometimes one works better than others for a while. Eventually I do get all my mail, but my logs are riddled with these errors.
Post Reply